
Apéndice A

Manual de Usuario

El primer apéndice corresponde al manual de usuario de la herramienta desarrolla-

da Hydra en el que se detallarán los conceptos básicos para desarrollar un modelo de

caracteŕısticas.

Primero relataremos como instalar y desinstalar Hydra dentro de Eclipse 3.5 para

luego explicar su uso aśı como atajos de teclado y pequeñas acciones para una rápida y

cómoda creación de nuestro modelo de caracteŕısticas.

A.1. Instalación y desinstalación de Hydra

Hydra está embebido en Eclipse, por lo tanto, el primer paso es obtener este IDE

de su página oficial1. Después de descargarlo tenemos que descomprimirlo dentro de una

carpeta elegida.

Hydra depende de TEF, para ello tendremos que instalarlo previamente desde su

UpdateSite2.

1http://www.eclipse.org/downloads
2http://tef.berlios.de/updatesite
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A. Manual de Usuario

A.1.1. Instalación

1. Una vez instalado Eclipse, vamos a Help→ Install New Software. . .

2. Escribimos en “Work with” la dirección donde está nuestro plugin:

“http://caosd.lcc.uma.es/spl/hydra/”

3. Una vez instalado Eclipse, vamos a Help→ Install New Software. . .
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A.1. Instalación y desinstalación de Hydra

4. Seleccionamos Feature Modeling y pasamos a la siguientes secciones hasta instalar

Hydra.

A.1.2. Desinstalación

1. Abre Eclipse, y ve a Help→ About Eclipse.
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2. Click en Installation Details.

3. Seleccionamos Hydra Feature y le damos a desinstalar.
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A.2. Actualización

A.2. Actualización

1. Abre Eclipse, y ve a Help→ Check for updates. Si existe una nueva versión de Hydra,

aparecerá.

A.3. Gúıa de uso

A.3.1. Creación de proyecto Hydra

1. Para empezar a usar Hydra creamos un proyecto común. Para ello usamos File→
New→ Project . . . Le damos cualquier nombre y finalizamos.
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2. Una vez creado nuestro proyecto, crearemos un modelo de caracteŕısticas con Hydra,

para ello vamos a File→ New→ Other . . . y seleccionamos Featuremodel Diagram

dentro de la carpeta Hydra. Le podemos dar cualquier nombre, pero es importante

que no borremos la extensión del archivo al escribirlo (hydra diagram).

A.3.2. Entorno

Hydra es un plugin multipágina de Eclipse, de esta forma pretendemos que cada pro-

yecto sea lo más cómodo de editar posible. La primera pestaña corresponderá a nuestro

modelo de caracteŕısticas principal, en él crearemos las caracteŕısticas, añadiremos las

relaciones entre ellas y editaremos sus atributos. La segunda pestaña contiene el editor de

restricciones en el que escribiremos las restricciones que impĺıcitamente no se puedan mo-

delar mediante el diagrama de caracteŕısticas previamente modelado. Conforme hagamos

especializaciones (desde nuestro modelo de caracteŕısticas principal o desde otra especia-

lización), aparecerán nuevas pestañas que corresponderán a los modelos de caracteŕısticas

de dichas especializaciones. En estos editores únicamente podremos seleccionar o elimi-

nar caracteŕısticas (especializar nuestro modelo) con el fin de ir reduciendo el número de

productos posibles.

Ficheros creados

Analizando el explorador de proyectos podemos ver que se han creado unos nuevos

ficheros. El fichero con la extensión “hydra diagram” será nuestro principal fichero, en él

está almacenado el aspecto gráfico de nuestro modelo principal. El fichero con extensión

“hydra” será donde esté almacenado el modelo como en formato XMI. El fichero con

extensión “exp” será nuestro editor de restricciones. Los ficheros “hydra cfg diagram” y
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A.3. Gúıa de uso

“hydra cfg” corresponden al aspecto gráfico y al modelo Ecore de nuestras configuraciones.

Por último, el fichero “xml” almacena algunos datos de configuración de Hydra.

Creación de elementos

Si abrimos nuestro fichero principal nos encontraremos con el entorno gráfico de mo-

delado de caracteŕısticas de Hydra. La ventana principal será el lienzo, que es donde

dibujaremos las caracteŕısticas.

A la derecha podemos ver la paleta de herramientas en el podemos ver que existen 4

acciones de creación divididas en nodos y enlaces. En nodos podemos crear caracteŕısticas

y grupos de caracteŕısticas. En los enlaces podemos crear enlaces entre caracteŕısticas y

enlaces hacia o desde grupos de caracteŕısticas.

Para utilizar estas herramientas seleccionaremos alguna de ellas y seguidamente pin-

charemos en el lienzo si queremos crear nodos o en los nodos que queremos enlazar si

queremos crear enlaces.

En la paleta existen además algunos botones que nos permiten crear notas y botones

para alejar y acercar nuestro lienzo como si fuese un zoom.

Si tuviésemos que crear un modelo de caracteŕısticas de esta forma tardaŕıamos mucho

tiempo, para ello se han creado atajos.

Si seleccionamos una caracteŕıstica y hacemos click derecho en él, aparece un menú con-

textual. Dentro de Feature Actions podemos ver tres posibles acciones.
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1. Create Feature. Esta acción nos crea una caracteŕıstica hija y la pone en modo

edición.

2. Create FeatureGroup and Feature. Esta acción crea un grupo de caracteŕısticas hijo

y una caracteŕıstica dentro de ella en modo edición.

3. Create sibling. Crea una caracteŕıstica hermana independientemente de si su padre

es una caracteŕıstica o un grupo de caracteŕısticas.

Estas tres acciones también están asignadas a atajos de teclado, concretamente “Ctrl

+ 7”, “Ctrl + 8” y “Ctrl + 9” respectivamente.

Modificar atributos

Existen dos objetos que tienen tres estados, estos estados dependen de los valores que

posean, concretamente de los valores de la cardinalidad que tengan. Según sean estos valo-

res, su tipo (que es derivado de estos dos valores) será diferente, y también aśı su aspecto

visual. Estos objetos son los grupos de caracteŕısticas y las relaciones entre caracteŕısticas.

Para las relaciones entre caracteŕısticas tenemos los tipos OPTIONAL, MAN-

DATORY y SIMPLE que corresponden a cardinalidades 〈0.,1〉, 〈1.,1〉 y 〈m..n〉
(siendo m ≤ n, m ∈ N, n ∈ N∪∞) respectivamente. Para escribir el ĺımite superior

como infinito introduciremos cualquier número negativo, se representará como * en

el diagrama y conceptualmente corresponderá al infinito.

Para los grupos de caracteŕısticas tenemos los tipos XORGROUP, ORGROUP

y SIMPLE que corresponden a cardinalidades 〈1.,1〉, 〈1..#hijos〉 y 〈m..n〉 (siendo

m ≤ n ≤ ]hijos,m ∈ N, n ∈ N) respectivamente.

Para cambiar entre estos tipos podemos modificar los atributos directamente en las

propiedades del objeto (podemos modificar tanto las cardinalidades inferiores y superiores

como el tipo del objeto) o bien haciendo doble click en su figura correspondiente con el

que cambiaremos rápidamente de tipo.

En la parte inferior podemos ver las propiedades de nuestros elementos (si no se ven,

hacemos click derecho en cualquier parte del lienzo y le damos a Show properties view)

que serán diferentes para cada uno de los tipos de elementos. Estos son el proyecto los

dos nodos y los dos enlaces.
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A.3. Gúıa de uso

En ellos podemos editar algunos parámetros y ver los valores de otros.

Si nos fijamos, a la izquierda de los atributos aparecen dos pestañas, “Core” y “Ap-

pearance” donde podemos modificar aspectos gráficos de nuestro modelo, como colores

de las caracteŕısticas, tipo de letra, tamaño. . .

Acciones

Eliminar elementos Si queremos eliminar nodos o enlaces creados (únicamente en el

modelo de caracteŕısticas principal), los seleccionaremos y haremos click derecho en

ellos, escogiendo Delete from Model.

Exportar diagrama En el caso de que queramos exportar nuestro diagrama como una

imagen, podremos hacer esto haciendo click derecho en el lienzo, File→ Save as

image File.
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Ordenar diagrama Si queremos ordenar el diagrama, hacemos click derecho en el lienzo

y seleccionamos Arrange all.

Acciones principales Existen un grupo de acciones globales cuyo acceso se realiza me-

diante botones de acciones o dentro del menú contextual Hydra.

Estas acciones son de izquierda a derecha:

Especializar un modelo. Este botón permite crear una configuración a partir

del modelo que esté en ese momento mostrándose. Podemos especializar tanto

nuestro modelo de caracteŕısticas principal, como una especialización de él

para crear una más espećıfica. De esta forma podemos decir que Hydra tiene

la capacidad de crear configuraciones por etapas.

Validar restricciones de usuario. Comprueba que las restricciones de usua-

rio estén correctamente creadas. Esta acción se realiza automáticamente al

guardar el diagrama.

Validar el diagrama. Vuelve a validar nuestro modelo de caracteŕısticas. Esta

acción se realiza automáticamente cada vez que cambiamos de modelo y sea

pertinente ejecutarse.

Eliminar configuración. Elimina la configuración que se muestra del editor

multipágina, aśı como los ficheros que lo representan.

Crear configuración mı́nima. Calcula la solución mı́nima de nuestro modelo

de caracteŕıstica y crea una configuración con ella.

Crear configuración mı́nima con fichero de restricciones externo. Es-

ta acción crea una configuración teniendo en cuenta además de los requisitos

mı́nimos (restricciones estructurales del modelo inicial y restricciones de usua-

rio) que las caracteŕısticas escritas en un fichero dado deben de estar presentes
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A.3. Gúıa de uso

en dicha configuración mı́nima. Esta acción está diseñada espećıficamente para

satisfacer las necesidades de una compañera del grupo GISUM3.

Las acciones que creen una nueva configuración no realizarán su cometido a no

ser que el modelo de caracteŕısticas principal esté correctamente construido y las

restricciones de usuario estén bien formuladas.

Exportar restricciones Si queremos exportar nuestro fichero de restricciones a un for-

mato Ecore podemos hacerlo haciendo click derecho en el fichero de restricciones

(extensión “ext”), y seleccionamos Constraint menu → Generate XML.

Desreferenciar caracteŕıstica En caso de que queramos que una caracteŕıstica que

referencia a otra deje de referenciarla y tomar sus propios hijos tendremos que se-

leccionar dicha caracteŕıstica, hacer click derecho en ella y seleccionar “Unreference”.

3Grupo de Ingenieŕıa del Software de la Universidad de Málaga
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Selección y eliminación de caracteŕısticas en configuraciones

Como se comentó anteriormente, no existe la posibilidad de crear nuevos elementos en

las configuraciones. Esto es aśı para asegurar la pertenencia al modelo de caracteŕısticas

original. Por tanto no existe paleta de creación de elementos ni tampoco está permitida

la modificación de los atributos de los elementos (exceptuando el nombre de las carac-

teŕısticas).

En el editor gráfico de configuraciones básicamente sólo se pueden hacer dos acciones,

seleccionar una caracteŕıstica o eliminarla.

Para seleccionar una caracteŕıstica, tendremos que hacer doble click en la relación que

va hacia dicha caracteŕıstica. Automáticamente se propagará el efecto de dicha selección

por el diagrama para mantener el diagrama consistente.

Si lo que queremos es eliminar una caracteŕıstica de nuestro modelo, sencillamente

tendremos que hacer doble click en la caracteŕıstica elegida, provocando la eliminación

del subárbol que tiene como ráız a la caracteŕıstica eliminada, además de propagarse por

el resto del diagrama.

Recuperación de caracteŕısticas eliminadas

En el caso de que hayamos eliminado una caracteŕıstica y queramos recuperarla (en

el caso de que sea posible recuperarla, si la caracteŕıstica que queremos recuperar es una

caracteŕıstica muerta, el validador no nos dejará recuperarla) hacemos click derecho en la

caracteŕıstica padre y seleccionamos del menú contextual la opción Restore.
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A.3. Gúıa de uso

Aparecerá una ventana con dos listas, inicialmente en la lista de la izquierda aparecerán

las caracteŕısticas que han sido eliminadas y podemos recuperar mientras que en la lista de

la derecha se colocarán las caracteŕısticas que queremos recuperar. Para ello seleccionamos

cada caracteŕıstica y le damos al botón Add o hacemos doble click sobre ella.

Una vez terminada la selección, pulsamos Ok y se iniciará el proceso de recuperación

de los subárboles completos que tienen como ráız a las caracteŕısticas seleccionadas.

Recordar que esta acción sólo se puede hacer en el editor de configuraciones y que

aunque se vaya a recuperar el subárbol, el validador comprobará si existe alguna carac-
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teŕıstica de las que se van a recuperar que viole el estado de satisfacibilidad del diagrama,

eliminándola de la recuperación.
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